1.290,00 EUR

ONE TIME OFFERWant our advanced Metatrader Backtesting Training? Learn how to use historical testing to avoid making mistakes in algo trading.

Check YES to add this to your order now for just €197 €47 billed today

(This offer is not available at ANY other time or place)

An account already exists with this email address. Is this you? Sign in

Sign in
Ewtmlqrdt0hi4phmm0lv forex strategy builder professional

Forex Strategy Builder Professional Software - lifetime license

FSB Pro software took 15 years to build and is a more advanced version of the Forex Robot Factory online tool. FRF was made to be simple and online, FSB Pro is the opposite. 

If you are looking for more complex backtesting features and custom indicator options as well as customization, then this will be a great supplement. It brings a whole new level of understanding in automatic trading.

Forex Strategy Builder Professional provides an array of tools when it comes to strategy analysis: environment backtest and report; complete orders and positions journal; detailed indicator and account charts. Backtests can be run with one of several interpolation methods. Multi-market tests can be run with a single click. FSB Pro also comes with many Monte Carlo test options. Not only does FSB Pro give you Real Out of Sample testing and various interpolation methods, but it also makes sure it keeps you away from common logical errors. The program is getting frequent updates with bug fixes and new features.

There are more than 100 technical indicators bundled with the default install of FSB Pro. We make sure you can export strategies that use those indicators as Expert Advisors. FSB Pro allows you to extend it using custom technical indicators and addons written in C#. You can write those yourself, ask for help on the forums or pay someone to code those for you.

The program allows you to study the behaviour of your strategies in the deepest detail. This happens by using different methods of calculating the historical test and lower timeframe data.

  • It is a desktop software that can be used offline on a Windows machine
  • It uses multithread algorithm and can utilize the full power of your CPU
  • The program has user interface with Tabs, which give you opportunities to work with several strategies and even to run several Strategy Generators. However, for a best performance, you can open several copies of FSB Pro.
  • FSB Pro has advanced backtesting engine and provides 5 different interpolating algorithms.
  • The program detects the so called Ambiguous Bars and makes the safest possible calculations (Pessimistic algorithm), which guarantees that the real live results are always equal or better than the test.
  • FSB Pro can import historical files (.HST) from MT with one click.
  • It has a detailed Overview of the strategy’s trading rules.
  • The program has an advanced strategy structure. You can set indicators that determines the entry and the exit points of the position.
  • FSB Pro supports adding and reducing the positions on a next entry signal.
  • It provides entry size in fixed lots or per-cent of the account.
  • There is a special tool – Method Comparator, which calculates and shows the strategy performance by using all interpolations methods. This tool shows how reliable is the backtest on bar data.
  • FSB Pro can import and use Tick Data from Jforex, but because the special structure of the strategy and the advanced backtesting algorithm the Bar based data are fully reliable.
  • FSB Pro comes with about 100 integrated indicators and it also supports custom indicators written in C#. Currently our community has developed about 100 more custom indicators.
  • FSB Pro collects the generated strategies in collections and allows easy sorting and filtering. You can have more than one Strategy Collection

System Requirements

Recommended Hardware:
CPU: a modern 4 cores processor. RAM: 8 GB or more.

Minimal Hardware:
CPU: 2 cores processor, RAM: 2 GB.

Software Requirements:
Supported OS: Windows XP, Vista, 7, 8, 8.1, 10.
Microsoft .NET 4.0 or a newer version. MetaTrader 4 or MetaTrader 5.